nixos/system/services/hyprland.nix
2025-01-16 13:59:51 +01:00

18 lines
340 B
Nix

{ config, pkgs, ... }:
{
programs.hyprland = {
enable = true;
extraPackages = with pkgs; [
kitty
];
portalPackage = pkgs.xdg-desktop-portal-hyprland;
};
services = {
displayManager = {
autoLogin.enable = true;
autoLogin.user = "mbeno";
};
logind.extraConfig = "IdleAction=ignore";
};
}